Export limit exceeded: 417696 CVEs match your query. Please refine your search to export 10,000 CVEs or fewer.

Search

Search Results (417696 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2026-101990 2 Juniper, Juniper Networks 4 Junos, Junos Os Evolved, Junos Os and 1 more 2026-10-30 9.8 Critical
A Stack-based Buffer Overflow vulnerability in the routing protocol daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows a remote configured BGP peer to cause an rpd crash, or on Junos OS remote code-execution, via sending a flow-spec update which is selected for re-advertisement.
CVE-2026-119591 2 Redhat, Sqlite 2 Hummingbird, Sqlite 2026-10-30 5.5 Medium
SQLite before 3.54.0 contains a stack exhaustion vulnerability in countOfViewOptimization() that allows attackers to crash the host process via count(*) over a large multi-row VALUES clause. Attackers supplying SQL or a database file with a crafted view can trigger deeply nested TK_PLUS expressions whose recursive freeing in sqlite3ExprDeleteNN() exhausts the C stack, causing denial of service.
CVE-2026-119586 1 Sqlite 1 Sqlite 2026-10-30 7.8 High
SQLite command-line shell through 3.54.1 contains a command injection vulnerability in the .recover command that emits attacker-planted dot-commands stored in sqlite_schema.sql values verbatim. Attackers can craft a database whose schema holds a valid CREATE statement followed by a .shell or .system line, executing OS commands when victims pipe .recover output into sqlite3.
CVE-2026-119378 2 Redhat, Sqlite 2 Hummingbird, Sqlite 2026-10-30 5.5 Medium
SQLite before 3.54.0 contains a use-after-free vulnerability in the R-Tree extension that allows attackers to make applications use freed heap memory by manipulating the %_node shadow table. Attackers can supply a database declaring %_node WITHOUT ROWID or with a RAISE(IGNORE) trigger so nodeWrite() hashes nodes as 0, crashing the process after node splits.
CVE-2026-119373 2 Redhat, Sqlite 2 Hummingbird, Sqlite 2026-10-30 7.8 High
SQLite before 3.54.0 built with FTS5 contains a heap buffer overflow in fts5MergeRowidLists() that undersizes the output buffer when merging detail=none prefix doclists. Attackers who can populate a detail=none FTS5 table with negative rowids and run a prefix MATCH query can write past the allocation, corrupting heap memory and crashing the process.
CVE-2026-66025 2026-10-30 N/A
This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.
CVE-2026-119526 2026-10-30 9.8 Critical
Deserialization of Untrusted Data vulnerability in ThemeREX Royal Event allows Object Injection. This issue affects Royal Event: from n/a through 2.0.
CVE-2025-57848 1 Redhat 1 Container Native Virtualization 2026-10-30 6.4 Medium
A container privilege escalation flaw was found in certain Container-native Virtualization images. This issue stems from the /etc/passwd file being created with group-writable permissions during build time. In certain conditions, an attacker who can execute commands within an affected container, even as a non-root user, can leverage their membership in the root group to modify the /etc/passwd file. This could allow the attacker to add a new user with any arbitrary UID, including UID 0, leading to full root privileges within the container.
CVE-2025-11537 1 Redhat 2 Build Keycloak, Build Of Keycloak 2026-10-30 5 Medium
A flaw was found in Keycloak. When the logging format is configured to a verbose, user-supplied pattern (such as the pre-defined 'long' pattern), sensitive headers including Authorization and Cookie are disclosed to the logs in cleartext. An attacker with read access to the log files can extract these credentials (e.g., bearer tokens, session cookies) and use them to impersonate users, leading to a full account compromise.
CVE-2026-118086 2026-10-30 8.8 High
Subscriber Privilege Escalation in WP BASE Booking <= 6.5.2 versions.
CVE-2026-116852 2026-10-30 9.1 Critical
Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.
CVE-2026-107868 2026-10-30 5.3 Medium
Unauthenticated Bypass Vulnerability in YITH WooCommerce Product Add-Ons <= 4.34.0 versions.
CVE-2026-90888 2026-10-30 9.8 Critical
Unauthenticated PHP Object Injection in LeadSnap <= 1.25 versions.
CVE-2026-54855 2026-10-30 7.1 High
Unauthenticated Cross Site Scripting (XSS) in Profile Builder <= 4.0.5 versions.
CVE-2026-54854 2026-10-30 6.3 Medium
Contributor Privilege Escalation in Profile Builder <= 4.0.5 versions.
CVE-2026-48201 2026-10-30 7.1 High
Unauthenticated Cross Site Scripting (XSS) in Fast Velocity Minify <= 3.5.7 versions.
CVE-2026-39732 2026-10-30 9.3 Critical
Unauthenticated SQL Injection in Transliterator <= 2.5.13 versions.
CVE-2026-27061 2026-10-30 6.5 Medium
Subscriber Cross Site Scripting (XSS) in User Registration <= 5.3.0 versions.
CVE-2026-61789 1 Bytebase 1 Dbhub 2026-10-30 N/A
DBHub is a database MCP server for Postgres, MySQL, SQL Server, Oracle, MariaDB, SQLite. Prior to 0.22.6, read-only SQL validation can be bypassed on the MySQL and MariaDB connectors. In `src/utils/sql-parser.ts`, `scanSingleLineComment` treats every double dash as a comment start, whereas MySQL and MariaDB require following whitespace, a control character, or the end of the line. The read-only check in `src/tools/execute-sql.ts` validates split statements with `isReadOnlySQL`, but `src/connectors/mysql/index.ts` and `src/connectors/mariadb/index.ts` execute the original string with `multipleStatements` enabled. A double dash followed by a non-whitespace character can therefore hide a subsequent write or destructive DDL statement from the validator while the database interprets the dashes as minus operators and executes both statements. Anyone able to influence the assistant's SQL, including through prompt injection in content the assistant reads, can bypass read-only mode to modify or drop database data, subject to the database account's privileges. PostgreSQL is not affected by this path because its double-dash parsing agrees with the checker and its connector executes individual split statements. This issue is fixed in version 0.22.6.
CVE-2025-6017 1 Redhat 2 Acm, Advanced Cluster Management For Kubernetes 2026-10-30 5.5 Medium
A flaw was found in Red Hat Advanced Cluster Management through versions 2.10, before 2.10.7, 2.11, before 2.11.4, and 2.12, before 2.12.4. This vulnerability allows an unprivileged user to view confidential managed cluster credentials through the UI. This information should only be accessible to authorized users and may result in the loss of confidentiality of administrative information, which could be leaked to unauthorized actors.